虚拟机兼容性

来自BetaWorld 百科

综述

像Microsoft Office,Windows 一样,虚拟机也是有兼容性设置的。但对于Beta爱好者来说,虚拟机的兼容性不仅仅是为了让较低版本客户端运行在较高版本客户端所创建的虚拟机环境,还可以让一些在高版本虚拟机软件客户端完成不了的事情成为现实。

虚拟机兼容性的用处

  • 某些早期版本的 Windows Longhorn 的 DCE,视觉特效必须使用 VMware Workstation 5.x~6.x 兼容性才能开启,显示。
  • 某些版本的 Windows Whistler 在 VMware Workstation 上安装前,需要 VMware Workstation 5.x~6.x 兼容性。

如何调整虚拟机兼容性

到目前为止,除了 VMware 以外,大部分的虚拟机兼容性调整都只能通过安装对应版本完成。下面介绍 VMware Workstation 的兼容性调整方法。

在虚拟机创建过程中

选择“新建虚拟机”,选择“自定义创建”,在“选择虚拟机版本”中,选择所需要的兼容性。

已完成创建虚拟机

  • 右键虚拟机,在管理子菜单中选择“更改硬件兼容性”
  • 选择所需的兼容性

1:“创建此虚拟机的新克隆”或“更改此虚拟机”由实际需要而定。

2:更改虚拟机兼容性可能会导致某些设置好的硬件参数被移除或更改,具体标准请参照 VMware 知识库